פרויקט strongSwan: פתרון VPN מבוסס IPsec עבור Windows
StrongSwan הוא לקוח VPN מבוסס IPsec חינמי ובקוד פתוח זמין לרוב מערכות ההפעלה. הוא מיישם את פרוטוקולי חילופי המפתחות IKEv1 ו-IKEv2 כדי להחליף מפתחות הסמכה בין מארחים ולקוחות. יש כאן הרבה מונחים טכניים שצריך להבין, החל מ-IPsec ולאחר מכן לעבור ל-IKE.

VPN של strongSwan
להבין ולעבוד עם פרויקט strongSwan זה לא משחק ילדים, אלא זה דורש ידע מעמיק והבנה ברורה של פרוטוקולי אינטרנט ותכונות אבטחה אחרות הקשורות לכך.
להלן רשימת הפיצ'רים שנלקחה מהאתר הרשמי של strongSwan, הרשימה עשויה לכלול כמה מונחים קשים אבל סקרנות תמיד הייתה המורה הגדולה ביותר. אז פנו לגוגל או בינג, וחפשו וכך תלמדו יותר עליהם:
- רץ על ליבות לינוקס 2.6, 3.x ו-4.x, אנדרואיד, פריBSD, OS X ווינדוס
- מיישם גם את פרוטוקולי חילופי המפתחות IKEv1 ו-IKEv2 (RFC 7296)
- תמיכה שנבדקה לחלוטין בחיבורי מנהרות IPsec ותחבורה של IPv6
- עדכון כתובת IP דינמית וממשק עם IKEv2 MOBIKE (RFC 4555)
- הכנסה והסרה אוטומטית של כללי חומת אש מבוססי IPsec
- NAT-מעבר באמצעות הקפסולציה של UDP ושיטוט פורטים (RFC 3947)
- תמיכה בפיצול הודעות IKEv2 (RFC 7383) כדי להימנע מבעיות עם פיצול IP
- זיהוי עמית מת (DPD, RFC 3706) מטפל בטונלים תלויים
- כתובות IP וירטואליות סטטיות ומצבי משיכה ודחיפה של IKEv1 ModeConfig
- פונקציות של שרת ולקוח XAUTH מעל אימות מצב ראשי IKEv1
- בריכת כתובות IP וירטואליות מנוהלת על ידי דמון IKE או בסיס נתונים SQL
- אימות משתמשים מאובטח IKEv2 EAP (EAP-SIM, EAP-AKA, EAP-TLS, EAP-MSCHAPv2 וכו')
- הפניית הודעות EAP לשרת AAA באמצעות תוסף EAP-RADIUS היא אופציונלית
- תמיכה בהחלפות הזדהות מרובות של IKEv2 (RFC 4739)
- אימות בהתבסס על תעודות X.509 או מפתחות משותפים מראש
- שימוש באלגוריתמים חזקים לחתימה עם אימות חתימה ב-IKEv2 (RFC 7427)
- שחזור והזנה מקומית של רשימות ביטול תעודות באמצעות HTTP או LDAP
- תמיכה מלאה בפרוטוקול סטטוס תעודות מקוון (OCSP, RFC 2560).
- ניהול CA (כתובות URI של OCSP ו-CRL, שרת LDAP ברירת מחדל)
- מדיניות IPsec חזקות המבוססות על תווי אלא או CA ביניים
- אחסון מפתחות פרטיים של RSA ותעודות על כרטיס חכם (ממשק PKCS #11)
- תוספים מודולריים עבור אלגוריתמים של מטבעות קריפטוגרפיים וראיונות למסדי נתונים רלציוניים
- תמיכה בקבוצות DH בעקומות אליפטיות ותעודות ECDSA (Suite B, RFC 4869)
- מבחני שלמות וקריפטו מובנים בחירה עבור תוספים וספריות
- אינטגרציה חלקה של Linux בשולחן העבודה באמצעות התוסף של strongSwan NetworkManager
- חיבור רשת מהימן תואם ל-PB-TNC (RFC 5793) ול-PA-TNC (RFC 5792)
strongSwan פועל באופן מלא על מערכות הפעלה לינוקס, וחבילות הפצה זמינות גם כן. עם זאת, עדיין לא זמינה חבילת הפצה עבור Windows, ואתם צריכים לבנות את הקוד בעצמכם באמצעות כלי MinGW. לא כל הפיצ'רים זמינים ב-Windows, והרבה מגבלות קשורות לפרויקט. כדי להריץ את strongSwan כראוי, אתם צריכים להשבית את שירות ה-IKE המקומי ב-Windows וכמה אחרים.
ההתקנה וההגדרה על Windows כרגע מעייפות, אך צפוי שהפרויקט יפתח בקרוב חבילות בינאריות ניתנות להתקנה כדי להקל על כך.
אתה יכול לקרוא יותר על strongSwan עבור מערכת ההפעלה Windows כאן.
פרויקט strongSwan מתוחזק על ידי אנדריאס שטפן, פרופסור לאבטחת תקשורת באוניברסיטת המדעים המדויקים בראפרסוויל, שווייץ. הוא גם נתמך על ידי חברות אבטחת IT גדולות, כולל Secunet, Sophos ו-RevoSec.
strongSwan היא יישום כתוב היטב של IPsec. היא לגמרי קוד פתוח וזמינה ללא עלות. אתה יכול להוריד אותה, לבנות אותה בעצמך ואז ליצור את הרשת הווירטואלית שלך. על אף שזה דורש ידע טכני כלשהו כדי להבין את הפעולה ואת הקוד, אתה יכול לבדוק את התיעוד של הפרויקט כדי ללמוד עוד על כך ולקרוא את הוראות ההתקנה ופרטים נוספים.
מה זה VPN של StrongSwan?
כפי שהשם מרמז, strongSwan הוא אפליקציית VPN הבנויה על IPsec. הכוונה העיקרית שלה היא לספק אבטחה ברמה הגבוהה ביותר. החלק הטוב ביותר הוא שניתן להוריד ולהשתמש בה על פלטפורמות רבות, כולל Windows, Android, Mac, Linux וכו'.
איך אני מגדיר VPN מאתר לאתר ב-StrongSwan?
כדי להגדיר VPN בין אתרים עם strongSwan, אתה זקוק לכמה דברים. לדוגמה, השרת הווירטואלי זקוק לכתובת IP ציבורית, לכתובת IP פרטית, לשער וכו'. שנית, אתה זקוק לשרת וירטואלי ולשרת מרוחק כך שהשרת המרוחק יכול לשמש כרשת פרטית וירטואלית. בנוסף, עליך להיות בעל הכתובת החיצונית ומסכת ה-subnet בפורמט 1.1.1.1.
לך לכאן אם אתה מחפש תוכנת VPN חינמית עבור מחשב ה-Windows שלך.